Install vsftpd version 3 to fix writable root error OOPS 500

Below information is taken from Stack Overflow

Install vsftpd v3 via repo

echo "deb http://ftp.us.debian.org/debian jessie main contrib non-free" >> /etc/apt/sources.list
apt-get update
apt-get install -y --force-yes vsftpd

If the post-setup script fails, delete it so it doesn’t keep bothering you

cd /var/lib/dpkg/info && rm vsftpd.postinst

Allow writable chroot

echo "allow_writeable_chroot=YES" >> /etc/vsftpd.conf
service vsftpd restart

Or via package (no instructions)

https://packages.debian.org/jessie/init-system-helpers
https://packages.debian.org/jessie/vsftpd

Other config I use for first-time setup

#anonymous_enable=YES
local_enable=YES
write_enable=YES
chroot_local_user=YES

Leave a Reply

Your email address will not be published. Required fields are marked *